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1. RELEASE NOTES

Version Date Comments

1.0 5/5/2021 Initial version

This document and its contents are confidential. It is not legally binding. Any reproduction
and / or distribution of all or part of this document or its content to a third party is strictly
prohibited or subject to prior written authorization from Lyra Collect. All rights reserved.
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2. MODULE FEATURES

The payment module offers the following functionalities:

• Immediate payment

• Compatibility with GiveWP version 2.x

• Multi-language compatibility

• Multi-currency compatibility

• Automatic redirection to the shop once the payment is made

• Custom 3D Secure depending on the order amount

• Systematic registration of orders at the end of payment via a silent URL (Instant Payment Notification
URL)
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3. READ CAREFULLY BEFORE GOING ANY FURTHER

The most frequent error concerns the Instant Payment Notification URL. The Instant Payment Notification
URL is the only way the Lyra Collect gateway can notify you at the end of your payment. The chapter
Setting up the end of payment notification must be read thoroughly and the provided instructions must
be respected. It is essential to understand the difference between the Instant Payment Notification URL
and the return URL which is called only if the buyer clicks on “Return to shop”.

Frequent errors:

• Your GiveWP shop is in maintenance mode

• Your Instant Payment Notification URL is protected by an .htaccess file

• You have blocked the IP addresses of the payment gateway

• You have not encoded the notification URL in the Expert Back Office

How to check that the Instant Payment Notification URL has been called:

Via the Expert Back Office, display the payment details (double click), then go to the “Event log” tab.
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4. PREREQUISITES

Before integrating the payment module, please make sure that you are in possession of the following
elements:

• Payment module file: Lyra_GiveWP_2.x_v1.0.x.zip

• Your shop ID

• Test or production key

The Shop ID and the keys are available in the Expert Back Office (menu: Settings > Shop > Keys)

Reminder, your Expert Back Office is available at this address:

https://secure.lyra.com/portal/

Click “Other actions” and sign into your Expert Back Office.

WARNING: All our payment modules are tested, starting from PHP version 5.3.

Therefore, all the previous PHP versions are no longer supported by our modules. If you have an earlier
version, you must ask your hosting provider to install a more recent version on your server prior to
contacting us.

Please note that the 5.3 version is no longer supported by PHP: http://php.net/supported-versions.php
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5. INSTALLING AND CONFIGURING THE PAYMENT MODULE

5.1. Updating the module

To update the payment module, you must first disable and then delete the previous version.

WARNING: Make sure you save the parameters of your module before you deactivate it and, most
importantly, save the production key that is no longer visible in your Expert Back Office.

1. From the Wordpress Back Office, go to the Plugins > Installed Plugins menu.

2. Search for the Lyra Payment for GiveWP module.

3. To deactivate the payment module, click Deactivate.

4. Then click on Delete in order to delete the module from your shop.

5. The procedure for installing a new module is described in the next chapter.

5.2. Adding the payment module

The Lyra Collect payment module can be added in two ways:

Automatic installation:

The first method consists in adding the payment module via the WordPress Back Office:

1. Sign in to your WordPress Back Office.

2. Go to Extensions > Add.

3. Click the Upload Plugin button.

4. Click Browse and search for the payment module on your hard drive.

5. Then click the Install now button.

Manual installation:

The second method consists in copying the module via FTP. To do this, copy the lyra-for-give folder into
the /wp-content/plugins/ folder of your website.

5.3. Activating the payment module

If you have not already enabled the Lyra payment module upon the installation:

1. Sign in to the Back Office WordPress.

2. Click Plugins > Installed Plugins.

3. Search for the Lyra Payment for GiveWP module.

4. Click Activate.
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6. CONFIGURING THE PAYMENT MODULE

1. In the WordPress back-end, go to Donations > Settings.

2. Click the Payment Gateways tab.

3. In the Enabled Gateways search for Lyra.

4. Click on the logo located to the left of Lyra while keeping the button pressed, then move it up to the
first position in order to propose Lyra first.

5. Modify the Label if you wish. Otherwise the label will be set to Donate with Lyra.

6. Click the Enabled button to enable the module.

7. Click the Default button to propose Lyra by default.

8. In the Gateways section located above Enabled Gateways, click Lyra to configure the module.

9. The details of each parameter are described in the following chapter.
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6.1. General configuration

Access to the payment gateway

Shop ID Indicate the 8-digit shop ID, available in your Expert Back Office (Menu: Settings >
Shop > Keys).

Test key Specify the test key available via your Expert Back Office (Menu: Settings > Shop >
Keys).

Production key Specify the production key available in your Expert Back Office (Menu: Settings >
Shop > Keys).

Mode Allows to indicate the operating mode of the module (TEST or PRODUCTION).
The PRODUCTION mode becomes available only after the test phase has been
completed.
The TEST mode is always available.

Signature algorithm Algorithm used to compute the signature of the payment form.
The algorithm must be the same as the one configured in the Expert Back Office
(Settings > Shop > Keys).
If the algorithm is different, the parameter will have to be modified via the Expert
Back Office.

Instant Payment Notification URL URL to copy in your Expert Back Office (Settings > Notification rules > Instant
Payment Notification URL at the end of the payment > Instant Payment
Notification URL of the API form V1, V2 menu).

Payment page URL This field is pre-populated by default: https://secure.lyra.com/vads-payment/

Payment page

Default language This option allows to choose the default language of the payment page in case the
language of GiveWP is not supported by Lyra Collect.
If the language(s) used by the GiveWP is (are) implemented into Lyra Collect, the
payment page will be displayed in the language of GiveWP when the buyer clicks on
“Pay”.

Available languages Allows to customize the language displayed on the payment page.
The buyer will be able to select a language when he or she is redirected to the
payment page.
If you do not select any language, all languages will be displayed on the payment
page.
To select a language, press and hold the “Ctrl” key and click on the desired
languages.
Available languages:
German, English, Chinese, Spanish, French, Italian, Japanese, Dutch, Polish,
Portuguese, Russian, Swedish, Turkish.

Capture delay Indicates the delay (in days) before the capture.
By default, this parameter can be configured in your Expert Back Office. (Menu:
Settings > Shop > Configuration - section: Capture delay)
It is recommended to not populate this parameter.

Validation mode Back Office configuration: Recommended value.
Allows to use the configuration defined in the Expert Back Office. (Menu: Settings >
Shop > Configuration section: validation mode)
Automatic:
This value indicates that the payment will be captured in the bank automatically
without any action on the merchant’s part.
Manual:
This value indicates that the transactions will require manual validation by the
merchant via the Expert Back Office.
Warning: if the transaction is not validated by the merchant before the expiration
date, it will not be captured in the bank.

Card types This field allows to select the cards logo to be displayed on the payment page.
Warning:
The payment types offered to the buyer on the payment page depend on the
contracts and options associated with your Lyra Collect offer.
It is recommended to leave this parameter empty.
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Custom 3DS

Managing 3DS This parameter is taken into account only if the store has the Selective 3DS1 or
Frictionless 3SD2 option.

• in 3DS1: Disables the 3DS1 process during an e-commerce payment. Requires
the Selective 3DS1 option.

IMPORTANT
This feature will become obsolete as soon as the 3DS1 version is no longer
supported by the networks.
As of October 2020, issuers can refuse the transaction if 3D Secure
authentication has not been performed.
This behavior is called “Soft Decline”.
To reduce the number of rejected payments, the payment gateway
automatically makes a new payment attempt with 3D Secure
authentication, when possible.

• in 3DS2: Allows to request authentication without interaction (frictionless).
Requires the Frictionless 3DS2 option.

• For payments made in euro, if the amount is lower than €30, a request
for frictionless is transmitted to the DS. If the request for frictionless is
accepted by the issuer, the merchant loses the payment guarantee.

• For payments made in euros, if the amount is greater than €30, the value
transmitted by the merchant is ignored and the management of cardholder
authentication is delegated to the gateway.

• For payments made in a currency other than euro, a request for frictionless
is transmitted to the DS.

Return to shop

Automatic redirection This option allows to automatically redirect the buyer to the merchant website. This
option depends on the following settings.
This option is disabled by default.

Time before redirection (success) If the automatic redirection option is enabled, you can define the delay in seconds
before your buyer is redirected to your shop in case of a successful payment.

Message before redirection (success) If the automatic redirection option is enabled, you can define the message that
will appear on the gateway following a successful payment before your buyer is
redirected to the shop.
The default message is:
“Redirection to the shop in a moment”.

Time before redirection (failure) If the automatic redirection option is enabled, you can define the delay in seconds
before your buyer is redirected to your shop in case of a failed payment.

Message before redirection (failure) If the automatic redirection option is enabled, you can define the message that will
appear on the gateway following a failed payment before your buyer is redirected
to the shop.
The default message is:
“Redirection to the shop in a moment”.

Return mode During the redirection to the shop, these parameters are returned to the shop in
GET or POST modes.
The GET mode is more convenient for the buyer as it allows to prevent the browser
from displaying a pop-up window that indicates that the buyer is leaving an https
environment for an http environment which obliges the buyer to click on “Accept”
to return to the shop.

Once you have completed the configuration, click Save.
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7. SETTING UP THE INSTANT PAYMENT NOTIFICATION URL

Several types of notifications are provided in the Expert Back Office. They allow to manage the events that
will generate a call to the merchant website and to configure the URL of the contact page.

To access notification rule management:

1. Sign in to: https://secure.lyra.com/portal/.

2. Click Other actions and sign into your Expert Back Office

3. Go to the following menu: Settings > Notification rules.

Figure 1: Notification rules

Right click > Enable the rule if a red cross appears in the Enabled column of the following rules:

• Instant Payment Notification URL at the end of the payment
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7.1. Setting up the Instant Payment Notification

This notification is required to communicate the result of a payment request.

In your Expert Back Office, you must set up a URL that will be systematically called after a payment. It will
inform the merchant website of the payment result even if your client has not clicked on return to the shop.

This parameter is called Instant Payment Notification URL at the end of the payment.

To set up this notification:

1. Right-click Instant Payment Notification URL at the end of the payment.

2. Select Enable the rule.

3. Right-click Instant Payment Notification URL at the end of the payment once again.

4. Select Manage the rule.

5. Enter the following URL in the fields URL to call in TEST mode and URL to call in PRODUCTION mode
(Notification URL of the Hosted payment page V1, V2 section):

http://www.your-domain.com/?give-action=handle_lyra_response

Replace your-domain.com with the domain name of your website.

6. Enter the E-mail address(es) to notify in case of failure.

7. To specify several e-mail addresses, separate them with a semi-colon.

8. Set up the parameters for Automatic retry in case of failure.

This option allows to automatically send notifications to the merchant website in case of failure (up to
4 times).

A notification will be considered as failed if the HTTP code returned by the merchant server is not on
the following list: 200, 201, 202, 203, 204, 205, 206, 301, 302, 303, 307, 308.

Automatic retry does not apply to notifications manually triggered via the Expert Back Office.

Call attempts are scheduled at fixed intervals every 15 minutes (00, 15, 30, 45). After each failed
attempt, a notification e-mail is sent to the e-mail address specified earlier.

9. Save the changes.
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7.2. Testing the Instant Payment Notification URL

In order to make sure that the Instant Payment Notification functions correctly, follow these steps:

1. Make sure that your URL is available online: your shop must neither be in maintenance mode nor be
protected by an .htaccess file.

2. Make sure that your notification URL is available without any redirection.

a. To do this, paste your notification URL to the address bar of your browser and launch the search.

b. Make sure your URL did not change.

If your URL has changed, for example from "http" to "https" or "http://abc.net" to
"http://www.abc.net", it means a redirection is active on your website. Then, copy the URL from
the address bar and modify the URL filled in the configuration of all notification rules.

3. Make sure that the "Automatic redirection" option is disabled in the payment module settings.

4. Check that the Instant Payment Notification URL at the end of payment is populated in the Expert
Back Office (see above).

5. Make an order on your website and proceed to payment.

6. Do not click on "Return to shop" at the end of payment and close the current tab of your browser.

7. In the Donations > Donations menu, check that the order status is Complete.

If the order status is still Pending, this means that the call has failed.

If the payment gateway is unable to access the URL of your page, an e-mail will be sent to the shop
administrator.

It contains:

• The HTTP code of the encountered error,

• Parts of error analysis,

• Its consequences,

• Instructions to resend, from the Expert Back Office, the notification to the URL already specified above.
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8. PROCEEDING TO TEST PHASE

One the payment module is configured and you have set up the notification URLs, it is possible to test
the payment module.

The test phase is not mandatory, however, we recommend to make some tests to make sure that the
payment solution has been correctly integrated.

Different cases of payments can be simulated by using test card numbers specified on the payment page.
The Merchant will be able to test all 3D Secure authentication results (if the Merchant is enrolled and 3DS
is not disabled).

To perform the test phase:

1. Make an order on your merchant website as if you were one of your buyers.

2. Select the payment method "Payment by credit card".

3. Once you have been redirected to the payment page, select the card type of your choice.

4. Click on one of the card numbers on the payment page.
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9. SHIFTING THE SHOP TO PRODUCTION MODE

After you receive a confirmation e-mail informing you that your shop has been created in the production
environment, you can configure the payment method by following the steps below:

• Retrieve the shop ID and the production key available in the Expert Back Office (Settings > Shop> Keys
).

• In the module configuration parameters:

• Replace the Production key field.

• Select the PRODUCTION mode.

• Save the changes.

• Make sure that you have specified the Instant Payment Notification URL in production mode, as
described in the chapter Setting up the Instant Payment Notification URL.

Once the production settings have been configured, we recommend to make a first real payment.

You will then be able to cancel the payment via the Expert Back Office. This transaction will not be captured
in the bank.

Note on the production key:

For security reasons, this key will no longer be visible as soon as the first transaction in production mode
is made in your shop.
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10. OBTAINING HELP

Looking for help? Check our FAQ on our website

https://docs.lyra.com/en/collect/faq/sitemap.html

If you have any technical questions or need assistance, our tech support is available

from Monday to Friday from 9 a.m. to 6 p.m.

by phone at:

by e-mail : support-ecommerce@lyra-collect.com
and via your Expert Back Office, Help > Contact support

To facilitate the processing of your demands, you will be asked to communicate your shop ID (an 8-digit
number).
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