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1. RELEASE NOTES

Version Date Comment
4.1.0 13/05/2020 Initial version.

This document and its contents are confidential. It is not legally binding. Any reproduction
and / or distribution of all or part of this document or its content to a third party is strictly
prohibited or subject to prior written authorization from Lyra Collect. All rights reserved.
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I 2. MODULE FEATURES

e Immediate payment.

e Payment in installments.

e Multi-language compatibility.

e Multi-currency compatibility.

e Selective 3D Secure depending on the order amount.

e Automatic redirection to the shop once the payment is made.

e Definition of a minimum/maximum amount for each payment type.

e Configuration of the order status in case of success / failure / cancellation.

e Possibility to notify the Buyer in case of a refused or canceled payment.

e Systematic registration of orders at the end of payment via a silent URL (Instant Payment Notification
URL).

Functionalities not available via the payment module:

e 1-Click payment.

e Automatic update or orders OpenCart in case of validation, duplication, cancellation, refund,
modification via the Expert Back Office.

e Update in OpenCart of the final result of a deferred payment.

e Update in OpenCart of an expired payment if a payment with manual validation has not been validated
in time by the Merchant.
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3. READ CAREFULLY BEFORE GOING ANY FURTHER

The most frequent error concerns the Instant Payment Notification URL. The Instant Payment Notification
URL is the only way the Lyra Collect gateway can notify you at the end of your payment. The chapter
Setting up the end of payment notification must be read thoroughly and the provided instructions must
be respected. It is essential to understand the difference between the Instant Payment Notification URL

and the return URL which is called only if the buyer clicks on “Return to shop”.

Frequent errors:

If your OpenCart shop is in maintenance mode
If your Instant Payment Notification URL is protected by an .htaccess file
If you have blocked the IP addresses of the payment gateway

If you have not encoded the notification URL in the Expert Back Office

How to check that the Instant Payment Notification URL has been called:

Via the Expert Back Office, display the payment details (double click), then go to the “Event log” tab.

) Details of a transaction in progress: 615145 (Order reference: 29)

@ Details | [a5) 3D Secure g Buyer | 4 Extra | Delivery “% Shopping cart || | 3, Risk assessment | || Event log
Date = Operation User Details

18/06/2019 17:05:22 Merchant confirmation e-mail in progress BATCH to: vin...

18/06/2019 17:05:22 Buyer confirmation e-mail in progress BATCH to: sy...

18/06/2019 17:05:22 Instant Payment Notification E_COMMERCE

g Complementary information: Instant Payment Notification

SENT, rule=URL de notification a la fin du paiement, duration=~1,4s, response= <span style="display: none;"=0K-Accepted payment,
order has been updated. </span=¢-¢-&-¢

X Close
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I4-. INSTALLMENT PAYMENT FEATURES

This module also allows you to offer the possibility to pay in installments. In module settings, you can
choose the number of installments and the delay in days between each installment.

This module will allow you to view an order in your OpenCart Back Office with the total amount that has
been paid using the “payment in 3 installments with no fees” module, for instance.

During the first installment payment, an authorization request for the amount of the first installment is
sent (if the capture date is before the current date + 6). Therefore, you cannot be sure that the upcoming
installments will be honored. Remember to check that the upcoming installments are authorized.

Starting from the second installment, the IPN is no longer called, as OpenCart does not support such
notifications for finalized orders. It is needless to resend the IPN from the Back Office.

However, it is possible to be notified by e-mail in case one of the following installment payments is refused.
All you need to do is enable and configure the Installment payment rejection e-mail rule. This rule can be
found in the Settings > Notification rules menu > E-mail sent to the merchant tab of the Expert Back Office.

Additional feature implemented into this module.

For installment payments, the Lyra Collect payment gateway allows to also choose the amount of the first
installment.

Example:

For an amount of 100 EUR in 3 installments, you can set the percentage of the first payment at 50% of
the amount. This means that the amount of the first installment will be 50 EUR and that the two others
will be of 25 EUR.

Payment method view

In module settings, you can define the minimum amount starting from which you wish to offer installment
payment.

You can also set up the maximum amount until which you wish to offer installment payment.

To sum up, you must define a range for enabling payment in installments.
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5. PREREQUISITES

Before integrating the payment module, please make sure that you are in possession of the following
elements:

e Payment module file: Lyra_OpenCart_3.x_v4.1.x.ocmod.zip

e Your shop ID

e Test or production key

The Shop ID and the keys are available in the Expert Back Office (menu: Settings > Shop > Keys )

.2 Configuration MOTO payment settings ’ Keys ]=| Reports || [_] MID association

, Keys of the API form V1, V2 and WS (all versions)

Shop ID: 2 83 Production key: 763100 2055
Test key: 541 6231 Date of the shift to live mode: 16/02/2018 14:22:18
ﬂ Regenerate a test key Last generation of the production key: 16/02/2018 14:22:18

ﬂ Regenerate a production key

Reminder, your Expert Back Office is available at this address:
https://secure.lyra.com/portal/

Click “Other actions” and sign into your Expert Back Office.

WARNING: All our payment modules are tested, starting from PHP version 5.3.

Therefore, all the later PHP versions are no longer supported by our modules. If you have an earlier version,
you must ask your hosting provider to install a more recent version on your server prior to contacting us.

Please note that the 5.3 version is already no longer supported by PHP: http.//php.net/supported-
versions.php
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I6. INSTALLATION AND CONFIGURATION OF THE MODULE

6.1. Update

To update the payment module, you must first delete its previous version.

WARNING: Make sure you save the parameters of your module before you uninstall it and save the
production key that is no longer visible in the Lyra Back Office.

Moreover, the new version of the module introduces a new setting: Signature algorithm. By default, this
field is set to HMAC-SHA-256 and its value must be the same as in the Lyra Collect Back Office (Settings >
Shop). If the algorithm is different, the parameter must be changed via the Lyra Back Office.

1. Go to Extensions > Extensions, then choose the Payments extension type.
2. Search for the old version of the installed module and click Uninstall (-).
3. Go to Extensions > Install and delete the old version of the module.

4. Go to the following chapter (First installation) on module installation.

6.2. First installation

1. In the OpenCart Back Office, go to Extension > Install and click the Download button.
2. Search for the payment module, then click the Install button.

3. If you encounter any difficulties in adding the module via the OpenCart Back Office, proceed to the
next step. Otherwise, move on directly to step 6.

4. Copy the admin, catalog and system folders located in the upload folder of the Lyra
Collect_OpenCart_3.x_v4.1.x.ocmod.zip file.

5. Paste these folders at the root of your website.

6. Go to Extensions > Extensions, select the Payments extension type, search for the Lyra Collect
module and click Install (+).
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6.3. Configuring the payment module

In order to configure the payment module, go to Extensions > Extensions. Choose Payments as an
extension type, search for the Lyra Collect - Standard payment module, then click Modify.

The payment module configuration is divided into several parts:

e General configuration: Concerns the general configuration of the module.

e Standard payment: Allows to enable and configure standard payments.

e Orders: Allows to configure the statuses and notifications of an order.

General configuration

Access to the payment gateway

Shop ID Specify the 8-digit shop ID available in your Expert Back Office (Menu: Settings >
Shop > Keys).
Test key Specify the test key available via your Expert Back Office (Menu: Settings > Shop >

Keys).

Production key

Specify the production key available in your Expert Back Office (Menu: Settings >
Shop > Keys).

Mode

Allows to indicate the operating mode of the module (TEST or PRODUCTION).
The PRODUCTION mode becomes available only after the test phase has been
completed.

The TEST mode is always available.

Signature algorithm

Algorithm used to compute the signature of the payment form.

The algorithm must be the same as the one configured in the Expert Back Office
(Settings > Shop > Keys).

If the algorithm is different, the parameter will have to be modified via the Expert
Back Office.

Instant Payment Notification URL

URL to copy in your Expert Back Office (Settings > Notification rules > Instant
Payment Notification URL at the end of the payment > Instant Payment
Notification URL of the API form V1, V2 menu).

Payment page URL

This field is pre-populated by default: https://secure.lyra.com/vads-payment/

Default language

Payment page

This option allows to choose the default language of the payment page in case the
language of OpenCart is not supported by Lyra Collect.

If the language(s) used by the OpenCart is (are) implemented into Lyra Collect, the
payment page will be displayed in the language of OpenCart when the buyer clicks
on “Pay”.

Available languages

Allows to customize the language displayed on the payment page.

Buyer will be able to select a language when he or she is redirected to the payment
page.

If you do not select any language, all languages will be displayed on the payment
page.

To select a language, press and hold the “ctr1” key and click on the desired
languages.

Available languages:

German, English, Chinese, Spanish, French, Italian, Japanese, Dutch, Polish,
Portuguese, Russian, Swedish, Turkish.

Capture delay

Indicates the delay (in days) before the capture.

By default, this parameter can be configured in your Expert Back Office. (Menu:
Settings > Shop > Configuration - section: Capture delay)

It is recommended to not populate this parameter.

Validation mode

Back Office Configuration: Recommended value.
Allows to use the configuration defined in the Expert Back Office. (Menu: Settings >
Shop > Configuration section: validation mode)

Automatic:

Payment module integration for OpenCart 3
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Payment page

This value indicates that the payment will be captured in the bank automatically
without any action on the merchant’s part.

Manual:

This value indicates that the transactions will require manual validation by the
merchant via the Expert Back Office.

Warning: if the transaction is not validated by the merchant before the expiration
date, it will not be captured in the bank.

Remember to configure the Instant Payment Notification rule on an operation
coming from the Back Office to update the order status in OpenCart.

Selective 3DS
Disable 3DS

Amount below which 3DS will be disabled.

Below this amount, 3DS risk assessment rules will not be applied. Leave empty to

use the payment gateway configuration.

WARNING:

The value of this field will be taken into account only if the option “Selective 3D-
Secure” is enabled for your Lyra Collect shop.

This option can only be enabled upon agreement of your bank.

Some card types, such as MAESTRO, require a mandatory 3DS authentication. In
this case, your configuration will not be taken into account.

Return to shop

Automatic redirection

This option allows to automatically redirect the buyer to the merchant website. This
option depends on the following settings.

This option is disabled by default.

Time before redirection (success)

In case the automatic redirection option is enabled, you can define the delay
in seconds before your buyer is redirected to your shop in case of a successful
payment.

Message before redirection (success)

In case the automatic redirection option is enabled, you can define the message
that will appear on the gateway following a successful payment before your buyer
is redirected to the shop.

The default message is:

“Redirection to the shop in a moment”.

Time before redirection (failure)

In case the automatic redirection option is enabled, you can define the delay in
seconds before your buyer is redirected to your shop in case of a failed payment.

Message before redirection (failure)

In case the automatic redirection option is enabled, you can define the message
that will appear on the gateway following a failed payment before your buyer is
redirected to the shop.

The default message is:

“Redirection to the shop in a moment”.

Return mode

During the redirection to the shop, these parameters are returned to the shop in
GET or POST modes.

The GET mode is more convenient for the buyer as it allows to prevent the browser
from displaying a pop-up window that indicates that the buyer is leaving an https
environment for an http environment which obliges the buyer to click on “Accept”
to return to the shop.

Once you have completed the configuration, click Save.

Standard payment

Setup of the payment module

Activation In order to enable the payment method, select Enabled.
This mode est set to Enabled by default.
Order If you offer several payment methods, enter a number in the Sort order field to

determine the position of this payment method.
The payment methods appear in ascending order according to the Sort order value.

Payment area

Define the payment area to which this payment method will apply.
The All value means that the module applies to all areas.

Logs

Allows to enable or disable module logs.

Payment module integration for OpenCart 3
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Setup of the payment module

This parameter is enabled by default.

Restrictions

Minimum amount This field defines the minimum amount for which you wish to offer this payment
method.

Maximum amount This field defines the maximum amount beyond which you do not wish to offer this
payment method.

Once you have completed the configuration, click Save.

Orders

Order state

Order status in case of success Select the order status from the list of accepted payment statuses.

Order status in case of failure Choose the order status from the list of declined payment statuses.

Order status in case of cancellation Choose the order status from the list of cancellation by the buyer statuses.

Notify the buyer in case of declined Select Yes if you want to notify the buyer by e-mail in case of a declined payment.
payment

Notify the buyer in case of cancellation | Select Yes if you want to notify the buyer by e-mail in case of cancellation.

Once you have completed the configuration, click Save.
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6.4. Payment in installments

In order to configure the payment module, go to Extensions > Extensions. Choose Payments as an

extension type, search for the Lyra Collect - Payment in installments module, then click Install (+).

Then, click Modify to access module configuration.

Installment payment module is configured in the same way as the standard payment module, except that

it is also possible to configure the payment option in the payment in installments tab.

The additional parameters are:

Payment options

First installment

Amount of the first installment, expressed as a percentage of the total amount.
Example :

For an amount of 100 EUR in 3 installments, you can

set the percentage of the first payment at 50% of the

amount. This means that the amount of the

first installment will amount to 50 EUR an that the two

others will be of 25 EUR.

For 50% enter 50.

If you wish to set identical amounts for all installments, leave the field empty.

Number Number of installments:
3 for payment in 3 installments
4 for payment in 4 installments
Etc.
Period Period (in days) between each installment.

Once you have completed the configuration, click Save.
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7. SETTING UP THE INSTANT PAYMENT NOTIFICATION URL

Several types of notifications are provided in the Expert Back Office. They allow to manage the events that
will generate a call to the merchant website and to configure the URL of the contact page.

To access notification rule management:
1. Sign in to: https://secure.lyra.com/portal/.
2. Click Other actions and sign into your Expert Back Office

3. Go to the following menu: Settings > Notification rules.

2 Instant Payment Notification [ E-mail sent to the merchant || ] E-mail sent to the buyer

Enabled 4 Reference
Instant Payment Motification URL on batch authorization
Instant Fayment Notification URL at the end of the payment
Instant Fayment Notification URL on batch change

Instant Fayment Notification URL on cancellation

XX XSEX

Instant Payment Motification URL on an operation coming from the Back Office

Figure 1: Notification rules
Right click > Enable the rule if a red cross appears in the Enabled column of the following rules:
¢ Instant Payment Notification URL at the end of payment

¢ Instant Payment Notification URL on cancellation

Payment module integration for OpenCart 3
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7.1. Setting up the Instant Payment Notification

This notification is required to communicate the result of a payment request.

In your Expert Back Office, you must set up a URL that will be systematically called after a payment. It will
inform the merchant website of the payment result even if your client has not clicked on return to the shop.

This parameter is called Instant Payment Notification URL at the end of the payment.

To set up this notification:

1.

2.

Right-click Instant Payment Notification URL at the end of the payment.
Select Enable the rule.
Right-click Instant Payment Notification URL at the end of the payment once again.

Select Manage the rule.

. Enter the following URL in the fields URL to call in TEST mode and URL to call in PRODUCTION mode

(Notification URL of the Hosted payment page V1, V2 section):

http://www.mon-domaine.fr/index.php?route=extension/payment/lyra/callback
Enter the E-mail address(es) to notify in case of failure.
To specify several e-mail addresses, separate them with a semi-colon.

Set up the parameters for Automatic retry in case of failure.

This option allows to automatically send notifications to the merchant website in case of failure (up to
4 times).

A notification will be considered as failed if the HTTP code returned by the merchant server is not on
the following list: 200, 201, 202, 203, 204, 205, 206, 301, 302, 303, 307, 308.

Automatic retry does not apply to notifications manually triggered via the Expert Back Office.

Call attempts are scheduled at fixed intervals every 15 minutes (00, 15, 30, 45). After each failed
attempt, a notification e-mail is sent to the e-mail address specified earlier.

Save the changes.
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7.2. Setting up notifications in case of abandoned or canceled payments

The payment gateway can systematically notify the merchant website:
e When the buyer abandons/cancels a payment - via the Cancel and return to shop button.
e When the buyer has not completed the payment and the payment session has expired.

The maximum length of a payment session is 10 minutes.
To set up this notification:
1. Right-click Instant Payment Notification URL on cancellation.
2. Select Manage the rule.
3. Enter the E-mail address(es) to notify in case of failure.

4. To specify several e-mail addresses, separate them with a semi-colon.

9]

. Set up the parameters for Automatic retry in case of failure.

This option allows to automatically send notifications to the merchant website in case of failure (up to
4 times).

6. Enter the following URL in the fields URL to call in TEST mode and URL to call in PRODUCTION mode
(Notification URL of the Hosted payment page V1, V2 section):

http://www.mon-domaine.fr/index.php?route=extension/payment/lyra/callback
7. Save the changes.
8. Once again, right-click Instant Payment Notification URL on cancellation.

9. Select Enable the rule.
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7.3. Testing the Instant Payment Notification URL

In order to make sure that the Instant Payment Notification functions correctly, follow these steps:

1.

6.

7.

Make sure that your URL is available online: your shop must neither be in maintenance mode nor be
protected by an .htaccess file.

Make sure that your notification URL is available without any redirection.

a. To do this, paste your notification URL to the address bar of your browser and launch the search.

b. Make sure your URL did not change.
If your URL has changed, for example from "http" to "https" or "http://abc.net" to
"http.//www.abc.net", it means a redirection is active on your website. Then, copy the URL from
the address bar and modify the URL filled in the configuration of all notification rules.

Make sure that the "Automatic redirection" option is disabled in the payment module settings.

Check that the Instant Payment Notification URL at the end of payment is populated in the Expert
Back Office (see above).

Make an order on your website and proceed to payment.
Do not click on "Return to shop" at the end of payment and close the current tab of your browser.

Make sure that the order has been created in the OpenCart Back Office.

If the order has not been created in the OpenCart Back Office, this means that the call has failed.

If the payment gateway is unable to access the URL of your page, an e-mail will be sent to the shop
administrator.

It contains:

The HTTP code of the encountered error
Parts of error analysis
Its consequences

Instructions to resend from the Expert Back Office the notification to the URL already specified above.
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I8. RENAMING THE PAYMENT METHOD

When the buyer is on the payment method selection page, by default, the Lyra Collect module will display:
Payment by credit card.

It is possible to personalize this label to display, for instance: Card payment with Lyra Collect
For this, open the lyra.php file, located in: Catalog\language\fr-fr\extension\payment
Replace Payment by credit card by the desired label:

S_['text_payment_lyra_title'] = 'Card payment with Lyra Collect';

S_['text_payment_lyra_multi_title'] = 'Card payment in %s installments with Lyra Collect’;

Payment module integration for OpenCart 3
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I9. PROCEEDING TO TEST PHASE

One the payment module is configured and you have set up the notification URLs, it is possible to test
the payment module.

The test phase is not mandatory, however, we recommend to make some tests to make sure that the
payment solution has been correctly integrated.

Different cases of payments can be simulated by using test card numbers specified on the payment page.
The Merchant will be able to test all 3D Secure authentication results (if the Merchant is enrolled and 3DS
is not disabled).

To perform the test phase:

1. Make an order on your merchant website as if you were one of your buyers.
2. Select the payment method "Payment by credit card".
3. Once you have been redirected to the payment page, select the card type of your choice.

4. Click on one of the card numbers on the payment page.
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I 10. SHIFTING THE SHOP TO PRODUCTION MODE

After you receive a confirmation e-mail informing you that your shop has been created in the production
environment, you can configure the payment method by following the steps below:

e Retrieve the shop ID and the production key available in the Expert Back Office (Settings > Shop> Keys
).

¢ In the module configuration parameters:
e Replace the Production key field.
e Select the PRODUCTION mode.
e Save the changes.

e Make sure that you have specified the Instant Payment Notification URL in production mode, as
described in the chapter Setting up the Instant Payment Notification URL.

Once the production settings have been configured, we recommend to make a first real payment.

You will then be able to cancel the payment via the Expert Back Office. This transaction will not be captured

in the bank.

Note on the production key:

For security reasons, this key will no longer be visible as soon as the first transaction in production mode
is made in your shop.
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I 11. OBTAINING HELP

Looking for help? Check our FAQ on our website

https://lyra.com/doc/fr/collect/faq/sitemap.html

If you have any technical questions or need assistance, our tech support is available

from Monday to Friday from 9 a.m. to 6 p.m.

oy shonc 0811900475 Jpcetiel

by e-mail : support-ecommerce@lyra-collect.com

and via your Expert Back Office, Help > Contact support

To facilitate the processing of your demands, you will be asked to communicate your shop ID (an 8-digit
number) .
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